More and more Mac apps are requiring Snow Leopard. I may have to bite the bullet and upgrade the rest of my machines.

View on Twitter

Hashtags

Mentions