Sprint’s Treo 600 Updater Isn’t for Me

I got an SMS (Sprint’s version) on my Treo 600 telling me I should go to http://sprintpcs.com/treo600/ and update my phone. Two things struck me when I got there:

  1. The page was unstyled and this message was at the top of the screen:
    Note: Because you are using an outdated browser, you may only view the raw textual content of this site. In order to view, use, and enjoy this site to the fullest at the maximum security level, please refer to our Browser Upgrade page to view a list of browsers that support web standards.

    Interestingly, on their Browser Upgrade page Camino and Firebird are both listed as supported browsers, yet both browsers are shown unstyled content. I think this is due to the way the links to the stylesheets are coded on that page, Camino works fine on other pages of their site. Anyone want to confirm/clarify?

  2. The requirements for running the updater include:
    Your operating system is Windows 95, 98, 98SE, ME, NT 4.0, 2000, or XP

    Bummer. I don’t want to set up the Treo on my PC; and besides that, the Treo 600 is sold as a Mac compatible device.

I hope the upgrade isn’t that important.